Symptom
- “OneTimeCustomer/Supplier" within the Business Object Interface I_JOURNALENTRYTP does not return a response when customer data is entered.
- Newly created customers are not reflected in the Business Partner
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Use the Business Object Interface I_JOURNALENTRYTP to post an accounting document to a one-time customer.
- Populate the substructure "OneTimeCustomerSupplier" with customer data.
- Execute the object and observe that no response is returned.
- Verify that the new customer is not reflected in the Business Partner.
Cause
The Business Object Interface I_JOURNALENTRYTP is not designed to create One-Time Customers. The One-Time Customers should be initially set up in the system before being utilized in the API.
Resolution
The same logic works for other SOAP APIs as well, such as Journal Entry - Post (Synchronous) and Journal Entry - Post (Asynchronous). Additionally, only one one-time customer allowed in the posting document.
See details in SAP Help Portal: DebtorItem -> OneTimeCustomerDetails
Keywords
i_journalentrytp, onetimecustomersupplier, substructure, business object interface, no response, customer ledger, business partner, accounting document, one-time customer, sap s/4hana cloud public edition, data management, customer data return , KBA , AC-INT-2CL , Accounting Interface (Public Cloud) , Problem
SAP Knowledge Base Article - Public