SAP Knowledge Base Article - Public

3637671 - Service Request Field Room/Building/Floor does not match length of ERP Fields

Symptom

When updating the Service Request field Room/Building/Floor, the following error message is displayed: "Your entry is too long. Do not enter more than 10 character(s)."

Environment

Cloud for Customer

Reproducing the Issue

  1. Go to the Service Work Center
  2. Go to the Ticket view
  3. Choose a ticket 
  4. In the ticket overview, click on the pencil icon
  5. In Service Location, look for the field called "Building/Floor/Room"
  6. Type any entry with more than 10 characters.

It is displayed the following error message: "Your entry is too long. Do not enter more than 10 character(s)."

Building, Floor and Room numbers are limited to 10 characters in C4C.

Cause

There are fields in C4C that have a maximum length of characters. Because of that, an entry that exceeds the field's standard length triggers a message of error.

The character limit of the Building/Floor/Room fields is 10 character long by standard.

Currently this is a limitation in C4C, with the length of the field.

Resolution

Please ensure that the entry has 10 characters at the maximum.

Alternatively, an extension scenario can be created where you use an Extension Field and map the IDOC element to it as well in the middleware. 

See Also

  • KBA 2593219 - Error 'Value is longer than the maximum permitted length X: ABC' In Web Service Message Monitoring
  • KBA 2533356 - Error Message: "Your entry is too long. Do not enter more than 10 Character(s)" 

Keywords

Cloud for Customer; Ticket; Building/Floor/Room; Service Request; Character; Length , KBA , LOD-LE-IBA-IPO , Installation Point , Product Enhancement

Product

SAP Cloud for Customer core applications 2505