Symptom
When trying to create a Ticket, error message "You are not authorized to create the ticket" is displayed.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service > Tickets.
- Click on new.
- Enter the requested information.
- Save.
- Error message is displayed.
Cause
When this error occurs, if the user is assigned to all required work centers as per described in KBA 2343326 - Access Restrictions And Context For Ticket Work Center Views, then the cause can be related to a Code List Restriction (CLR) implemented for Tickets BO.
If the cause is a CLR, then most likely a field will be highlighted in red in the Tickets quick create screen. If none is highlighted, please enable all fields via Adaptation Mode to confirm.
Resolution
Please follow below steps:
- Go to Service > Tickets.
- Click new.
- Click on men profile and Start Adaptation.
- Select each grey field and enable them.
- See if any field is highlighted by the system.
- Now go to Administrator > General Settings.
- Open Code List Restrictions link.
- Search for Business Object: Ticket
- Open all the CLRs found.
- Now check which Code List Restriction is using the highlighted field as a condition.
- Now, it is possible to either make a dummy change on the CLR, delete the condition row for this specific field, or deactivate the CLR completely.
- Save after the change made.
- Try creating a new Ticket.
Observation: sometimes making a dummy change can fix a temporary inconsistency. If it does not work, then please delete the condition or the Code List restriction itself and try again.
See Also
KBA: 2343326 - Access Restrictions And Context For Ticket Work Center Views
Keywords
QC, parameters, rule, line, remove, inactive, disable, shows, showing, shown, displays, displaying, occurred, occurring , KBA , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public