SAP Knowledge Base Article - Public

3637999 - Sales Order Changes to Completed Even When the Invoice Status is Not Started

Symptom

In the sales order ABC, it contains one item line and is partially delivered, but not yet invoiced. After entering the reason for rejection on item level, the sales order general status is updated to Completed even when the invoice is still Not Started status.

ABC represents the ID of the sales order.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Sales Orders view.
  3. Open the order ABC, the status is completed.
  4. Go to Items tab, the item delivery status is Finished, invoice status is Not Started.
  5. Go to the Customer Invoicing work center.
  6. Go to the Invoice Requests view.
  7. Search the invoice request based on sales order ABC, the outbound delivery invoice request DEF is with status To Be Invoiced. (DEF represents the ID of the outbound delivery)

Cause

Once the reason for rejection is maintained on the item level, the status of the sales order changes to Completed directly.

After saving the order, the delivery status is updated to Finished, the invoice status remains Not Started. And the outbound delivery invoice request remains To Be Invoiced status.

This is the current designed system behavior.

Resolution

It is possible to further invoice the outbound delivery invoice request DEF. Once it is invoiced, the invoice status in sales order ABC will be updated to Finished.

Keywords

sales order; status; completed; invoice status; not invoiced. , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign 2502 ; SAP Business ByDesign 2505