Symptom
The search results for accounts in the Outlook Add-in fetches all accounts including blocked and obsolete accounts. However, these accounts (blocked/obsolete) do not appear under the "All accounts" filter in SAP Cloud for Customer UI (C4C).
Environment
SAP Cloud For Customer
Outlook Integration
Reproducing the Issue
- Open the Outlook add-in for SAP Cloud for Customer.
- Navigate to the contact creation screen.
- Use the "Account Reference" field to search for an account.
- Observe that the search results display few accounts that are not part of the "All accounts" filter in C4C (fetches blocked/obsolete accounts as well).
Cause
The Outlook add-on retrieves account data through an OData API. The API payload includes All accounts, including blocked or obsolete ones. However, the C4C UI further applies a filter to display only active accounts, leading to a discrepancy between the add-on and the C4C UI.
This additional filter cannot be added into oData when fetched to outlook.
Resolution
This is a technical limitation.
Keywords
outlook add-on, contact creation, account search, sap cloud for customer, c4c, account reference, blocked accounts, obsolete accounts, odata api, search discrepancy, active accounts, groupware integration , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
SAP Knowledge Base Article - Public