Symptom
'Machine Translation' button does not translate the content of Email.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
- Navigate to Cases work center.
- Open a Case.
- Go to the Timeline Tab and expand an email.
- Click on the Machine Translation button.
- In the Translated Text section, select a language and click on Translate.
- Notice that the email content is not translated.
Cause
Input issue: The email content (Original Text) includes a mix of languages and significant portion of text (such as footer, signatures or disclaimers) is in a language other than the email content language and is much more in volume as compared to the email content which is not intended for translation.
Resolution
Below steps will help to improve the Machine Translation results:
- Click on the Machine Translation button of the Email.
- In the Original Text section, identify the portions of the email content that are not intended for translation and remove them.
- After making necessary adjustments, in the Translated Text section, select the desired language and click on Translate.
See Also
SAP Help Document - View Machine Translated Text
Keywords
Machine Translation, Translate, Original Text, Email, Case, Timeline, Show Translation, Not working, Language, Translated Text, Service Cloud , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public