SAP Knowledge Base Article - Public

3638896 - Dump happens when changing Page Layout of Tickets in Adaptation Mode

Symptom

A dump happens when trying to disable custom query across other page layouts: 

"An error occurred, please try again. If the case persists, report a case on component AP-RC-UIF-FLX-FRW."

Environment

Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center 
  2. Go to the Tickets view.
  3. Enter Adaptation mode.
  4. Click on the Pencil icon that covers the entire Ticket view
  5. On the right, click on "Ticket" option
  6. Click on "Implementation" option
  7. Click on "Queries" option
  8. Click on "All Closed Tickets" option (last option in the list)
  9. Change the page layout to any other layout and disable the query.
  10. Repeat step no 4 for 3 to 5 different page layouts.
  11. The system throws a short dump error.

Cause

The issue occurs because the system loses its internal reference when switching between different XML layers in the cache.

After a few changes, this can cause inconsistencies and result in a system dump.

Resolution

The recommended approach for handling this type of layout adaptation in flexible scenarios is as follows:

  1. When working in Adaptation Mode with the same source (e.g., the same query), please make sure to end the Adaptation Mode each time a change is made. This allows the system to merge changes properly and maintain consistency.
  2. If additional changes are necessary, please activate the Adaptation Mode again before proceeding.

In theory, this behavior would not occur if the changes involved different objects, such as two distinct fields.

Keywords

Cloud for Customer; Ticket; Object; Adaptation mode; dump; custom queries; pages layouts. , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , Problem

Product

SAP Cloud for Customer core applications 2505