Symptom
- Rule created to set a field visibility to 'view' only is not working in Onboarding, field remains editable
- Same rule is working as expected in EC pages (Add New Employee, Manage Pending Hires)
- When performing a rule trace for this rule in onboarding pages, observe that visibility rules trigger but have no effect on the fields
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Create onInit rule to set a field visibility to 'view'
- Save the rule under the relevant entity in Manage Business Config
- Create a rule trace
- Go to Add New Employee (EC), Rule is working as expected
- Go to Onboarding > New hire data, Rule did not have any effect, field is still editable
- In the rule trace see that the rule triggered but it did not work
Cause
This is expected behaviour:
- In Onboarding, the 'edit' permissions have priority. If user completing the task has 'edit' permission for the field, then the field will be editable even if the rule attempts to set it to 'view' only.
- In Employee Central, the rules have priority.
Please note: Some specific entities might behave differently.
Resolution
- Go to RBP Troubleshooting tool
- Search for the user completing the Onboarding task
- Find the role granting 'edit' permission for the relevant field
- Go to Manage Permission Roles > open that role
- Remove the 'edit' permission
See Also
KBA 2257064 - Employee Central - Business Rule Execution Log
Keywords
onInit rule not working, field visibility, view, fields, permissions, rule not setting visibility, edit permission, field still editable , KBA , LOD-SF-OBX-NHR , Onboardee Data Review , LOD-SF-OBX-PDC , Personal Data Collection , LOD-SF-OBX-EC , Integration EC - MPH, Hire , LOD-SF-OBX-DC , Personal Data Collection , Problem
Product
SAP SuccessFactors Onboarding
SAP Knowledge Base Article - Public