Symptom
When cancelling the two invoices together, which have different billing dates. The invoices are cancelled on the same date without any manual adjustments. The behavior is inconsistent between single and multiple billing document cancellations.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Select two billing documents for cancellation: one from the current period and one from the previous period.
- Cancel both billing documents simultaneously.
- The system created invoice cancellations with the same date for these two billing documents, without prompting for manual billing date updates for the previous period document.
Cause
Billing documents being cancelled together will have the same billing date. This is the standard system behavior.
Resolution
As a workaround, it is suggested to implement Flexible Billing Document Cancellation (SD_BIL_FLEX_CANCELLATION) to set up logic to influence the billing dates of each created cancelation billing documents.
See Also
Keywords
billing document, cancel, cancellation invoice, previous period, current period, billing date, update, flexible billing document cancellation, sd_bil_flex_cancellation, inconsistent, , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem
SAP Knowledge Base Article - Public