SAP Knowledge Base Article - Public

3639141 - Dump When Replacing File Name In Workflow Template Or Workflow Rules

Symptom

When Replacing File Name in Workflow Template or Workflow Rules,500 Internal Server error (Dump) occurs.  

Environment

SAP Cloud for Customer Core applications

Reproducing the Issue

  1. Go to Administration.
  2.  Workflow Rules.
  3. Open the workflow ABC (ABC Is Workflow Name).
  4. Click On Edit Action.
  5. Go to Step 3: Define Actions.
  6. Go To Template File Field.
  7. Browe File XYZ (XYZ Is File Name).
  8. Notice that dump occurs.

Cause

This issue occurs when the customer performs a partial refresh in the system. The root cause is that the workflow content is stored in attachments, which are not included in a partial refresh.

Resolution

  1. Go to Administration → Workflow Rules.
  2. Open the workflow ABC (ABC Is Workflow Name)
  3. Click On Edit Action.
  4. Go to Step 3: Define Actions
  5. Go To Subject field and click the pencil icon next to it.
  6. Select all the Entries and click on Remove Button. 
  7. Existing entries will be Removed and Click Ok Button.
  8. Then, click the pencil icon again and select Add Row to upload the new file.
  9. Click Ok Button.

 After following the above steps, replacing the file Dump will not Occur.

Keywords

LOD-CRM-SC-TMP, Dump, Template, Workflow, Replace , KBA , LOD-CRM-SC-TMP , Template , Problem

Product

SAP Cloud for Customer core applications all versions