Symptom
When Replacing File Name in Workflow Template or Workflow Rules,500 Internal Server error (Dump) occurs.
Environment
SAP Cloud for Customer Core applications
Reproducing the Issue
- Go to Administration.
- Workflow Rules.
- Open the workflow ABC (ABC Is Workflow Name).
- Click On Edit Action.
- Go to Step 3: Define Actions.
- Go To Template File Field.
- Browe File XYZ (XYZ Is File Name).
- Notice that dump occurs.
Cause
This issue occurs when the customer performs a partial refresh in the system. The root cause is that the workflow content is stored in attachments, which are not included in a partial refresh.
Resolution
- Go to Administration → Workflow Rules.
- Open the workflow ABC (ABC Is Workflow Name)
- Click On Edit Action.
- Go to Step 3: Define Actions
- Go To Subject field and click the pencil icon next to it.
- Select all the Entries and click on Remove Button.
- Existing entries will be Removed and Click Ok Button.
- Then, click the pencil icon again and select Add Row to upload the new file.
- Click Ok Button.
After following the above steps, replacing the file Dump will not Occur.
Keywords
LOD-CRM-SC-TMP, Dump, Template, Workflow, Replace , KBA , LOD-CRM-SC-TMP , Template , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public