SAP Knowledge Base Article - Public

3639255 - uploadIdPMetadata failed with 500 status error happens when verify account during single sign on configuration in SAC

Symptom

uploadIdPMetadata failed with 500 status error happens when verify account during single sign on configuration in SAC.

Environment

  • SAP Analytics Cloud 2025.8.18 (Client)
  • SAP Analytics Cloud 2025.8.17 (Server)

Reproducing the Issue

Steps in https://help.sap.com/docs/SAP_ANALYTICS_CLOUD/00f68c2e08b941f081002fd3691d86a7/3651184dad944aa2b361ad029a7a8cae.html.

When clicking the verify account button, below error can be confirmed in HAR trace:

{
    "message": "uploadIdPMetadata failed with 500 status",
    "stack": "",
    "errorDetails": [
        {
            "message": "uploadIdPMetadata failed with 500 status",
            "bUIMessage": false,
            "bWarning": false
        }
    ],
    "status": 500,
    "bUIMessage": false,
    "bWarning": false
}

Checked the metadata file, it works in other system like s/4 hana cloud.

Cause

The error was caused by the use of HTTP instead of HTTPS for endpoints in the customer's IdP metadata. The security policy in the CF environment strictly requires HTTPS for SSO and SLO endpoints. 

Resolution

- Modify the metadata to use HTTPS for all endpoints, including SLO and SSO. 

- Use SAP Cloud Identity Service (CIS) as a proxy to forward authentication requests to the customer's IdP.

Keywords

SSO, getACCESS, neo, cf , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0