Symptom
After generating the BPEM, the hierarchy is not displaying under the Utilities Financial facet on the Service Ticket.
Environment
- SAP Cloud for Customer
- SAP Cloud for Customer Integration with Utilities
Reproducing the Issue
- Go to the Tickets work center.
- Go to the Tickets work view.
- Search and open the Ticket ID 123456 (where 123456 means a generic ticket ID).
- Go to the Utilities Exceptions facet.
Outcome: No data available under Configurable Hierarchy table.
Cause
The requirements to create the Hierarchy is missing at S/4HANA. There is no Profile maintained on the S/4HANA.
Resolution
The steps to creating the configurable object hierarchy are listed below:
- In your SAP S/4HANA-IS Utilities system, use transaction code ENVD to create a configurable hierarchy.
- Next, assign the configurable hierarchy to IMG activity node Configure Object Hierarchy under SAP Customizing Implementation Guide SAP Utilities Cloud for Customer for Utilities Configure Object Hierarchy.
- Implement Web Service - ISU_C4C_CONF_HIER_GET. The web service reads the profile from the IMG node and sends it to the SAP Cloud for Customer system
This is documented at SAP Cloud for Customer Help Guide > Create Configurable Hierarchy. As soon as you set this properly, the web service reads the profile from the IMG node and sends it to the SAP Cloud for Customer system.
After configuring the S/4HANA system, whether the issue persists, please apply the SAP Note 3318234 - Configurable hierarchy doesn’t load due to large data volume
Keywords
Tickets, Utilities Exceptions, Configurable Hierarchy, Configurable, Hierarchy, C4C, Cloud for Customer, Utilities, BPEM, Exception. , KBA , LOD-CRM-IND-UTL , Utilities , How To
SAP Knowledge Base Article - Public