Symptom
When realizing the diagnosis step of an In-House Repair process, it's not possible to create a follow-up repair confirmation for the repair order.
Although the repair order is in status 'Released' and the repair object is in status 'Diagnosis: Perform', the popup for creating a follow-up is blank.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the app 'Perform Repairs'.
- Enter the concerned in-house repair.
- On the process flow, find the repair order and enter it.
- On the top-right corner, click on the button 'Create Follow-Up'
- The popup is blank and no follow-up document can be created.
Cause
Missing write access for the role SAP_BR_CUST_SRVC_TEC_REPA.
Resolution
Maintain the write access for this role on the necessary users so a follow-up document can be created.
See Also
Keywords
in-house repair order, repair object, released, diagnosis, perform prechecks, perform repair, prepare for billing, service confirmation, service order, perform diagnosis, repair order, repair confirmation, 3XK, IHR , KBA , CRM-S4-IHR-2CL , S4CRM: In-House Repair (Public Cloud) , Problem
SAP Knowledge Base Article - Public