Symptom
Error message "Enter a customer" when replicating Business Attributes to C4C for Registered Products via BusinessAttributeAssignmentReplicationRequestIn.
Environment
- SAP Cloud for Customer
- SAP Cloud for Customer integration with SAP ERP
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for erroneous message ID via service interface BusinessAttributeAssignmentReplicationRequestIn.
- Select the message and click on More > Error Log.
Error: Enter a customer
Cause
This is the standard behavior of the system.
The customer is mandatory for Registered Product. This validation was relaxed only for service interface RegisteredProductReplicationInitiatedByExternalIn along with few other validations based on the context parameter set in Inbound Service.
Resolution
If there is a requirement to skip the validation for BusinessAttributeAssignmentReplicationRequestIn, this will be a new requirement and need changes in Inbound Service and Business Object.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
The feasible approach is update Customer for the Registered Product via incoming service interface RegisteredProductReplicationInitiatedByExternalIn or maintain the Customer under Involved Parties on the Registered Product business object.
See Also
KBA 2581810 - Error Message "Enter a Customer" When Update Registered Product in C4C Replicated From ERP
Keywords
C4C, Cloud for Customer, Business Attributes, Registered Product, Item, Attributes, BusinessAttributeAssignmentReplicationRequestIn, RegisteredProductReplicationInitiatedByExternalIn, Registered, Product, Enter a Customer, Customer, ERP. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To
SAP Knowledge Base Article - Public