Symptom
It is expected that the tag <CustomerInvoiceRequestName> is included on the customer invoice's XML, however, it does not appear for some invoice documents.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Customer Invoicing workcenter.
- Go to the Invoice Documents view.
- Search for the ID ABC (Where ABC represents the relevant Customer Invoice ID).
- Click on Edit.
- Click on View All.
- Go to the Output History tab.
- Select View Original XML.
The field <CustomerInvoiceRequestName> is not included on the XML file as expected, while it appears for some other documents.
Cause
The tag <CustomerInvoiceRequestName> on the invoice's XML file represents the value in the "Description" field from the invoice request that precedes the Customer Invoice ABC.
However, if the Description is empty for this invoice request on the UI, the subsequent Invoice Document's XML will not have the tag included on the file (instead of containing the empty tag).
Resolution
This is the expected system behavior.
In case the tag is desired to be on the XML file of an invoice, a description must be maintained on the preceding invoice request.
Keywords
XML, CustomerInvoiceRequestName, description, customer invoice, output history, view original xml, field, not present, credit memo, manual credit memo request, byd. , KBA , SRD-CRM-INV , Customer Invoicing , How To
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