Symptom
- Service Organization field cannot be modified manually in cases.
- Service Organization field cannot be used when creating a case via API.
Environment
- SAP Service Cloud Version 2
- SAP Service Cloud and SAP Sales Cloud Version 2
Reproducing the Issue
- Open Cases Worklist
- Open any case
- Check Case details on the Side Pane
- Note that the "Service Organization" field is not editable
Cause
- Click on your User icon
- Go to Settings
- Click on "All Settings"
- Search for "Extensibility Administration" and open it
- Click on Field Attributes
- Select Case Service then Case
- Expand Service Organization and observe that the "Creatable", "Required", and "Updatable" attributes are disabled.
These are the settings that control and prevent you from editing this field manually, or via API
Resolution
The Service Organization field is currently designed to be determined automatically based on the Service Team assigned to the case, therefore it is disabled for any manual change.
Keywords
service organization, case management, sap service cloud version 2, field attributes, extensibility administration, creatable disabled, determined field, api case creation, manual modification, service team, Service Organization , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public