SAP Knowledge Base Article - Public

3640574 - Service Organization Details Cannot Be Modified In Cases

Symptom

  • Service Organization field cannot be modified manually in cases.
  • Service Organization field cannot be used when creating a case via API.

Environment

  • SAP Service Cloud Version 2
  • SAP Service Cloud and SAP Sales Cloud Version 2

Reproducing the Issue

  1. Open Cases Worklist
  2. Open any case
  3. Check Case details on the Side Pane
  4. Note that the "Service Organization" field is not editable

Cause

  1. Click on your User icon
  2. Go to Settings
  3. Click on "All Settings"
  4. Search for "Extensibility Administration" and open it
  5. Click on Field Attributes
  6. Select Case Service then Case 
  7. Expand Service Organization and observe that the "Creatable", "Required", and "Updatable" attributes are disabled.

These are the settings that control and prevent you from editing this field manually, or via API

Resolution

The Service Organization field is currently designed to be determined automatically based on the Service Team assigned to the case, therefore it is disabled for any manual change.

Keywords

service organization, case management, sap service cloud version 2, field attributes, extensibility administration, creatable disabled, determined field, api case creation, manual modification, service team, Service Organization , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions