Symptom
When creating an record in the system (e.g. Account, Employee, Contact) the date format is different from the V1.
Environment
- Sales Cloud V2
- Service Cloud V2
Reproducing the Issue
- Navigate to any entity in the tenant e.g. Employee
- Add a new entry
- Check any date field, e.g "Valid".
- The dates are displayed as "1/1/1" and "12/31/9999".
Cause
This behavior is expected and part of the system design.
The date formatting is rendered using JavaScript based on the user locale.
Resolution
The system will show the date format considering the users location settings (Browser). For example:
- DE: "1.1.1"
- EN (UK): "01/01/1"
- EN (US): "1/1/1"
Keywords
JavaScript, Date, Format, Employee, Valid, V1, V2, Location, Limitation , KBA , CEC-CRM-CHI , Change History for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public