Symptom
Updating the start and end date of an older appointment in C4C reverts the date back to the original after saving and syncing using server side integration
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open an older appointment in C4C.
- Change the start and end date from the older date to a date in the future.
- Save the changes and sync using server-side integration.
- Observe that the start and end date of the appointment revert back to the original after some time.
Cause
- The issue occurs due to a conflict during synchronization.
- The item was synchronized some time ago and fell out of the synchronization scope, but technical metadata remained intact on the Outlook side.
- When the start and end dates are updated in C4C, the reprocessing of the item is triggered. The Groupware ID is used to locate the corresponding item on the Exchange side.
- Two versions of the same event exist, one on each side, leading to a conflict. By default, the sync engine resolves the conflict by preferring the start and end date values from exchange.
Resolution
- This behavior is expected as the Exchange side always wins during the conflict resolution process by default.
- If necessary, tenant configuration can be adjusted so that C4C always wins in case of conflict. However, this adjustment may result in invitations being sent to attendees again.
See Also
Keywords
Appointment sync issue, c4c appointment date conflict, exchange sync conflict, c4c date reverts, groupware id conflict, server-side integration, invisible crm sync, c4c exchange conflict resolution, appointment metadata sync, c4c outlook sync issue, start and end date reverts, change date , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public