Symptom
- The error message "The table refresh for the model didn’t work properly" is displayed when attempting to refresh a report in the SAP Analytics Cloud Excel Add-in.
- The refresh option in the designer panel is marked in red, indicating that the table has not been refreshed.
- The issue happens in a specific SAC Add-in workbook and it works fine in other SAC Add-in workbooks.
- No missing name range is shown in the panel.
- In the Console tab of the developer's tool, there are some errors about 'Range'.
- Error Debug info:
{code: 'GeneralException', message: 'There was an internal error while processing the request.', errorLocation: 'Range.clear', statement: 'resizedRange.clear();', toString: ƒ, …}
- Error Debug info:
Environment
SAP Analytics Cloud, add-in for Microsoft Office
Reproducing the Issue
- Open the SAC add-in workbook.
- Observe that the refresh option in the designer panel is marked in red, indicating that the table has not been refreshed.
- Click on the refresh option, and the error message "The table refresh for the model didn’t work properly" is displayed.
Cause
The SAC Add-in workbook is corrupted and also contains a missing named range.
Resolution
- Log out of the SAC Add-in.
- Delete the affected sheet in the workbook.
- Log in again to SAC Add-in.
- Enable the "Restore Corrupted Workbook Objects" option.
- Restore the workbook objects.
- Refresh the report. The refresh operation should now work without any issues.
See Also
Keywords
SAC Excel Add-in, table refresh error, SAP Analytics Cloud, restricted measures, report-level calculations, corrupted workbook, missing named ranges, restore workbook objects, refresh option error, SAC planning model. , KBA , LOD-ANA-OF-XLA , SAP Analytics Cloud, add-in for Microsoft Office , Problem
Product
SAP Analytics Cloud all versions
SAP Knowledge Base Article - Public