Symptom
When trying to modify Business Rules in the the UI, a critical exception is raised: "An error occurred, please try again. 500 SAP Internal Server Error."
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Navigate to the Service and Social view.
- Open the Ticket Routing Rules by Employee.
- Select an entry with * placeholder.
Also occurs with other Business Rule UIs.
Cause
You have uploaded the Business Rules via excel and within the excel the same entry is marked as "is initial". This is supported by the framework and will activate and operate as expected at runtime but is a current limitation in the UI.
Resolution
Only use the excel upload for complex rule input.
Keywords
500 sap internal server error, ticket routing rules, c4c brf configuration, is initial, condition, add row dump, ITAB_ILLEGAL_SORT_ORD, excel upload rules, runtime functionality, UI conversion failure, BRF , KBA , LOD-CRM-BRF , C4C BRF Configuration , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public