SAP Knowledge Base Article - Public

3641800 - Exception on click of table row entry in Ticket Routing Rules

Symptom

When trying to modify Business Rules in the the UI, a critical exception is raised: "An error occurred, please try again. 500 SAP Internal Server Error."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Navigate to the Service and Social view.
  3. Open the Ticket Routing Rules by Employee.
  4. Select an entry with * placeholder.

Also occurs with other Business Rule UIs.

Cause

You have uploaded the Business Rules via excel and within the excel the same entry is marked as "is initial". This is supported by the framework and will activate and operate as expected at runtime but is a current limitation in the UI.

Resolution

Only use the excel upload for complex rule input.

Keywords

500 sap internal server error, ticket routing rules, c4c brf configuration, is initial, condition, add row dump, ITAB_ILLEGAL_SORT_ORD, excel upload rules, runtime functionality, UI conversion failure, BRF , KBA , LOD-CRM-BRF , C4C BRF Configuration , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions