Symptom
The desired column filter is not displayed in the filter list when accessing quotes. The issue occurs consistently across all users and all quote statuses.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Open a quote
- Select the "Filter items" icon (located next to the products table)
- Observe that the desired column filter is not displayed in the filter list.
Cause
There are 3 possible causes:
-
The quote item custom field isn't visible to users in Quote Layout Permissions.
-
"Use column value to filter quote items" isn't enabled.
- The quote item custom field isn't selected in Quote Layout.
Resolution
- Navigate to the "Setup" section
- Access "Quotes" and then select "Fields, Calculations, Layout"
- Go to "Layout Permissions" tab and check that the desired column filter is selected
- Go to "Layout" tab and check that the "quote item custom field" is added
- Go to "Fields Definition" tab and check that the toggle "Use column value to filter quote items" is enabled on the desired custom field.
See Also
Keywords
column filter missing, sto_icf_rabnetfilter, sales cloud cpq, layout permissions, filter not visible, quotes filter issue, production system, user type permissions, cpq filter configuration, cpq troubleshooting , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ 2025
SAP Knowledge Base Article - Public