SAP Knowledge Base Article - Public

3643384 - Why is our on-premise extractor not connecting to Signavio Process Intelligence?

Symptom

Why is our on-premise extractor throwing something like the following error when we run the start.sh/start.bat file?

Can't establish websocket connection to server -
sid-aba bash[786]: java.util.concurrent.ExecutionException: org.springframework.web.socket.sockjs.SockJsTransportFailureException: Failed to execute request to https://spi-etl-bridge.eu-prod-cloud-os-eu.suite-saas-prod.signav.io/signav>

Cause

This can be caused by the incorrect IP addresses being enabled on your Proxy/Firewall.

Resolution

Please take extra care to enable the right ones for your region. Just because you are located in one region, does not mean this is the regional server your application is running on.
IP addresses per region: https://help.sap.com/docs/signavio-process-intelligence/user-guide/regions-ip-addresses-and-urls?locale=en-US

Keywords

soe, process, intelligence, can't, connect, websocket, on, prem, extractor, error , KBA , BPI-SIG-PI-DM , Data model / ETL for SAP Signavio Process Intelligence , Known Error

Product

SAP Signavio Process Intelligence 3.0