SAP Knowledge Base Article - Public

3643568 - Notification of Another User Persists After Switching Accounts in the Byd Mobile App

Symptom

  • User receives notifications belonging to another user in the ByD mobile app.
  • Notifications persist even after switching accounts.
  • Clicking on the notifications does not grant access to the associated tasks.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Log into the ByD mobile app using user account "A".

  2. Without logging out, switch the login method to SSO for the same account.

  3. Log in with user account "B".

  4. Observe that notifications from user account "A" still pop up.

Note : A and B refers to two different user Accounts.

Cause

The user profile was not logged out from mobile application before switching to the SSO login method, resulting in residual data remaining in the application.

 

Resolution

Follow the below steps to resolve the issue:

  • Uninstall the ByD mobile application from the affected device.
  • Reinstall the ByD mobile application from the official app store.
  • Log in with the correct user account.

Keywords

ByD mobile app, notification issue, account switching, SSO login, user profile logout, persistent notifications, reinstall app, mobile notifications. , KBA , SRD-CC-MOB , Mobile Framework , Problem

Product

SAP Business ByDesign all versions