SAP Knowledge Base Article - Public

3644032 - cannot determine account origin for service in company XYZ during material cost estimate rollup

Symptom

  • Error message: "Cannot determine account origin for service in company XYZ encountered during material cost estimate rollup.
  • The error occurs for multiple materials, including Material ID: ABC.
  • The issue prevents obtaining up-to-date material cost estimates.

XYZ means Company

ABC means Material ID

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Inventory Valuation Work Center.
  2. Navigate to the Material Cost Estimates view.
  3. Identify Material ID: ABC with an exception.
  4. Click the "view" button.
  5. Go to the "Cost Breakdown by Item Type" tab.
  6. Here we can see that there is no Service ID maintained.
  7. Observe the error message: "Cannot determine account origin for service in company XYZ".

Cause

Missing account determination for services.

Resolution

Since the Service ID is blank it is necessary to maintain a new entry with blank account determination group for services

  1. Go to the Business Configuration Work Center.
  2. Choose the Implementation Projects view.
  3. Click the "Open Activity List" button.
  4. Navigate to the "Fine Tune" tab.
  5. Search for and select "Charts of Accounts, Financial Reporting Structures, Account Determination".
  6. Click the "Open" button.
  7. Select the "Account Determination -> Costs" option.
  8. Choose the "Account Determination Profile".
  9. Navigate to the "Costs" section and then to the "Service" tab.
  10. Maintain a new entry with blank account determination group for services.
  11. Save the changes.
  12. Retry the material cost estimate rollup.

Keywords

material cost estimate error, cannot determine account origin, service account determination, inventory valuation, material ID , account determination group, cost estimate rollup, missing service ID. , KBA , SRD-FIN-INV , Inventory , Problem

Product

SAP Business ByDesign all versions