Symptom
- Error message: "Cannot determine account origin for service in company XYZ encountered during material cost estimate rollup.
- The error occurs for multiple materials, including Material ID: ABC.
- The issue prevents obtaining up-to-date material cost estimates.
XYZ means Company
ABC means Material ID
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Inventory Valuation Work Center.
- Navigate to the Material Cost Estimates view.
- Identify Material ID: ABC with an exception.
- Click the "view" button.
- Go to the "Cost Breakdown by Item Type" tab.
- Here we can see that there is no Service ID maintained.
- Observe the error message: "Cannot determine account origin for service in company XYZ".
Cause
Missing account determination for services.
Resolution
Since the Service ID is blank it is necessary to maintain a new entry with blank account determination group for services
- Go to the Business Configuration Work Center.
- Choose the Implementation Projects view.
- Click the "Open Activity List" button.
- Navigate to the "Fine Tune" tab.
- Search for and select "Charts of Accounts, Financial Reporting Structures, Account Determination".
- Click the "Open" button.
- Select the "Account Determination -> Costs" option.
- Choose the "Account Determination Profile".
- Navigate to the "Costs" section and then to the "Service" tab.
- Maintain a new entry with blank account determination group for services.
- Save the changes.
- Retry the material cost estimate rollup.
Keywords
material cost estimate error, cannot determine account origin, service account determination, inventory valuation, material ID , account determination group, cost estimate rollup, missing service ID. , KBA , SRD-FIN-INV , Inventory , Problem
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public