Symptom
- Candidate cannot log in to the system after being identified as a Rehire with Old Employment (ROOE) during the onboarding process.
- Error message displayed: "Sorry, we could not authenticate you. Try again."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Enabled Retain Onboarding Username for Rehire on Old Employment in Onboarding General Settings page;
- Initiated Onboarding via ''Add new hire to onboarding';
- Completed New Hire Data Review step;
- Candidate sync to IAS, login system with username, completed Personal Data Collection step;
- Rehire verification triggered, identified the candidate as Rehire with Old Employment;
- Completed Rehire Data Review step, maintained candidate's personal email, Primary=yes;
- The personal email received reset password email from IAS;
- Candidate try to login via IAS with the personal email, error occurred: Sorry, we could not authenticate you. Try again.
Cause
There is a custom username field in the personal information entity, which has HRIS Sync mapping to ''Username'' field, causing the username to be overwritten during the rehire process.
Resolution
- Remove the HRIS Sync mapping for the custom username field from the personal information entity in "Manage Business Configuration."
- Refresh the OData metadata.
See Also
Keywords
rehire onboarding, IAS login error, rehire with old employment, sorry we could not authenticate you, second activation email, username inactive, HRIS Sync mapping, retain username, onboarding rehire verification, IAS reset password email, username HRIS Sync, Retain Onboarding Username for Rehire on Old Employment, Retain Onboarding Username doesn't work , KBA , LOD-SF-OBX-IAS , IAS User Authentication , Problem
SAP Knowledge Base Article - Public