SAP Knowledge Base Article - Public

3644122 - Sales Order can't be saved during the creation of a new customer project - SAP S/4HANA Cloud Public Edition

Symptom

Sales Order can’t be saved while creating customer project. the error message shown “Item1: item 0001: Pricing error( Mandatory condition TTX1 missing)”.

Environment

  • SAP S/4HANA Cloud Public Edition
  • SAP Central Business Configuration

Cause

SAP adds new incompleteness check for log of Incomplete procedure item “PS” to ensure mandatory pricing conditions are available for further FI posting processing.

Resolution

There are three options

  1. Complete mandatory pricing condition records defined in pricing procedure.
    For example:
    No tax classification maintained at all in business partner master data for the customer you are using in the project
    Tax condition (e.g. TTX1) record are not maintained or not in valid period

  2. Use own incompleteness check to replace SAP pre-delivered check
    a. Use SSCUI  101189 - Incompleteness Procedures" you can create a new incompletion procedure as same as "PS" and remove the entry for field "PRSOK".
    b. Use SSCUI 106831- Assign Incompleteness Procedures to Sales Item Categories, replace all the assigned procedure "PS" with your own procedure. Save the changes. 

  3. Create customer case with component IS-PRS-CNT, SAP will help to remove new check.

Keywords

Professional Services, Customer Project Management – Project-Based Services, Project Billing Item , KBA , IS-PRS-CNT , S/4 HANA: Professional Service Content , Problem

Product

SAP S/4HANA Cloud Public Edition all versions