Symptom
- The order of columns in the QA component (UI Designer / UI) does not match the configuration in the SDK.
- SDK - Code field should as expected be the first column, and Description should be the second column - this is inverted in the UI designer and the SDK
- The issue persists even after re-creating the BCC and QA component.
- Adaptation mode does not allow for adjustments via KUT.
Environment
- UI Framework Design time
- SAP Cloud for Customer
- SAP Business By Design
Reproducing the Issue
- Open BC -> Implementation projects.
- Open Activity list.
- Open respective activity.
- Observe that the column order is different from what is configured in the SDK.
Cause
- This is a known issue that occurs when a QA.uicomponent and relating BCC is deleted and the an adjustment made to or or both columns on the BCO in the SDK
- Re-creation of the BCC and QA component result in an inversion of columns
- Issue on the NetWeaver layer related to the proxy Business Object (BO) creation or update by the IF_MDRS_COMMON_MO_API~MODIFY method in the CL_MDRS_COMMON_MO_API class.
Resolution
Due to the potential knock on effects to the product with an attempt to correct this minor bug, the only options here are one of two work arounds.
- Unbind the table in the UI designer.
- Bind the description field only.
- Create a new field column in the primary position.
- Re-bind this column to the code field to match the desired sequence in the BCO.
OR
- Recreate the entire scenario, including the BCO, BCSet, and BCView.
Keywords
qa component, column order mismatch, bco, bcset, bcview, adaptation mode, sdk configuration, ui designer, netweaver, proxy bo, field sequence, unbind table, rebind columns, business configuration , KBA , AP-RC-UIF-DT , UI Framework Designtime , Problem
Product
SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public