SAP Knowledge Base Article - Public

3644487 - Created By field is not behaving as expected for Copy Tickets

Symptom

When creating a copy of Ticket, the Created By field shows the creator of the original Ticket instead of showing the user who created the copy Ticket.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service > Tickets.
  2. Open the desired Ticket.
  3. See field Created By = 'User1' (where 'User1' represents the name of the person who created it).
  4. Click on Actions > Copy button.
  5. Click on Save and Open button.
  6. The Created By field is displayed as 'User1', instead of showing the name of the person who just created the copy.

 

Cause

Despite existing a fine-tuning configuration to specify the determination of Created By of Tickets for Customer and Employee Support, when using the copy functionality, an identical copy of that object will be created. This means including field Created By. Hence, the user shown will be the creator of the original Ticket and not the user who created the copy Ticket.

Resolution

This is the expected behavior of the system.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

See Also

KBA: 3475641 - Functionality Currently not Available

Keywords

copying, copied, creating, version, involved parties, party, determination, current user, copied from employee, copied from contact, copied from contact of account, copied from individual customer, method, party role assignment, BC, fine tuning, fine-tune, activity, activities, business configuration, reported by, /Root/ReportedByPartyUUID, replaces, replaced, replacing, not working, does not work, doesn't work, wrong, incorrect, not correct , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions