Symptom
In Sales Quotes, the Item Progress cannot be updated directly in the Progress field.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Open the Navigation menu.
- Select the Sales Quotes view.
- Open an existing Sales Quote or create a new one.
- Go to the Products section.
- Add one or more Products.
- Observe that the Progress column shows Open.
- Note that there is no option to update the item progress directly.
Cause
Item-level Progress is determined by the Reason for Progress field, which is mapped in system settings to a specific Progress. Direct changes in the Progress field are not supported.
Resolution
1. Set up Reason for Progress mapping:
- Go to User menu.
- Settings > All Settings.
- Sales Quotes > Reason for Progress.
- Create a new Reason for Progress or edit an existing one under the desired Progress.
- Save the changes.
- Open an existing Sales Quote or create a new one.
- Go to the Products section and ensure the Reason for Progress field is visible.
2. How it works:
- If an Item has a Reason for Progress, the mapped progress applies to that Item, even if the header-level progress changes.
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Example: A Sales Quote contains five items — one item is set to Lost and four are Open. If the header-level progress changes to Won:
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The four Open items are updated to Won.
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The Lost item remains Lost.
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If an item does not have a reason for progress defined, its status will automatically update to match the header-level progress when it changes.
Keywords
Sales Quote, Item Progress, Status Field, Reason for Progress, Open, Lost, Won, CNS, Sales Cloud V2 , KBA , CEC-CRM-CQP , Sales Quote for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public