SAP Knowledge Base Article - Public

3644585 - Unable to Change Item Progress in Sales Quote

Symptom

In Sales Quotes, the Item Progress cannot be updated directly in the Progress field.

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open the Navigation menu.
  2. Select the Sales Quotes view.
  3. Open an existing Sales Quote or create a new one.
  4. Go to the Products section.
  5. Add one or more Products.
  6. Observe that the Progress column shows Open.
  7. Note that there is no option to update the item progress directly.

Cause

Item-level Progress is determined by the Reason for Progress field, which is mapped in system settings to a specific Progress. Direct changes in the Progress field are not supported.

Resolution

1. Set up Reason for Progress mapping:

  1. Go to User menu.
  2. Settings > All Settings.
  3. Sales Quotes > Reason for Progress.
  4. Create a new Reason for Progress or edit an existing one under the desired Progress.
  5. Save the changes.
  6. Open an existing Sales Quote or create a new one.
  7. Go to the Products section and ensure the Reason for Progress field is visible.

2. How it works:

  • If an Item has a Reason for Progress, the mapped progress applies to that Item, even if the header-level progress changes.
    • Example: A Sales Quote contains five items — one item is set to Lost and four are Open. If the header-level progress changes to Won:

      • The four Open items are updated to Won.

      • The Lost item remains Lost.

  • If an item does not have a reason for progress defined, its status will automatically update to match the header-level progress when it changes.

Keywords

Sales Quote, Item Progress, Status Field, Reason for Progress, Open, Lost, Won, CNS, Sales Cloud V2 , KBA , CEC-CRM-CQP , Sales Quote for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0