Symptom
When sending a GET call to API API_SUPPLIERINVOICE_PROCESS_SRV, the error SYSTEM_NO_ROLL occurs.
Environment
SAP S/4HANA Cloud Publice Edition
Reproducing the Issue
Send a GET call to the API API_SUPPLIERINVOICE_PROCESS_SRV as below:
<host>/sap/opu/odata/sap/API_SUPPLIERINVOICE_PROCESS_SRV/A_SupplierInvoice
Cause
The error occurs because the GET call retrieves all results without applying any filters, leading to a result set that is too large to be processed in a single call.
Resolution
Apply a filter to the GET call to limit the number of results returned. For example:
<host>/sap/opu/odata/sap/API_SUPPLIERINVOICE_PROCESS_SRV/A_SupplierInvoice?$top=100
Keywords
SYSTEM_NO_ROLL, GET call, API_SUPPLIERINVOICE_PROCESS_SRV, ODATA, A_SupplierInvoice, $top, runtime error, filter, supplier invoice , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , Problem
SAP Knowledge Base Article - Public