Symptom
- The error "CONFIGURATION_CENTER_INTERNAL_ERROR Error: [Empty response from Provider]" occurs in the Transport Center during the import of permission roles and permission groups.
- The issue arises when transporting data from one instance to another, specifically from a lower version instance to a higher version instance.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Attempt to transport permission roles using the Transport Center.
- Use a source instance running on version b2505 and a target instance running on version b2507 (monthly release salesdemo).
- Observe the error "CONFIGURATION_CENTER_INTERNAL_ERROR Error: [Empty response from Provider]" during the import process.
Cause
- The issue is caused by a version mismatch between the source and target instances. The source instance is on version b2505, while the target instance is on version b2507.
- Changes to MDF object permissions in version b2507 result in serialization failures during the import process from the lower version.
Resolution
- Confirm the version mismatch between the source and target instances.
- Waiting for both instances upgraded to the same version, specifically version b2511, to resolve the compatibility issue.
Note: The issue mightly also occurs when you are transporting a permission role from Product instance (b2505) to Preview instance (b2511) during b2511 release period.
Keywords
CONFIGURATION_CENTER_INTERNAL_ERROR, Empty response from Provider, Configuration Transport Center, Permission Roles, Version mismatch, MDF object permissions, SAP SuccessFactors, instance transport error, serialization failure. , KBA , LOD-SF-PLT-CGC , Configuration Center , Problem
Product
SAP SuccessFactors HCM Suite all versions
SAP Knowledge Base Article - Public