SAP Knowledge Base Article - Public

3645227 - Error "Transaction is being Processed by User SAP_WFRT" when Adding Multiple Service Items in Solution Order via Business Solution Order (A2X) API

Symptom

Error "Transaction is being Processed by User SAP_WFRT" occurs when attempting to add multiple service items to a solution order using the Business Solution Order (A2X) API (V2 or V4). The issue arises during the "second" API call to add subsequent items to the solution order.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Create multiple service items in a solution order using the Business Solution Order (A2X) API by sending multiple API requests.
  2. Observe that the first API request is processed successfully, but subsequent requests fail with the error: "Transaction is being Processed by User SAP_WFRT".

Cause

  • SAP_WFRT is the workflow user used to perform the backward updates on solution order. For instance, when a sales item is released from the solution order, the transaction history is updated by SAP_WFRT by locking the solution order. SAP_WFRT updates transaction history for project and based on the communication set up, sometimes for subscription billing items as well.
  • For service order/service contract items, unless there is any valid update performed on follow up service order, the solution order will not be locked by SAP_WFRT. This is the expected process flow in Solution Order.

Resolution

  1. Confirm whether other item types (e.g., sales items or subscription billing items) are being created in the same solution order, as these may trigger the locking mechanism.
  2. To avoid frequent locks, release all items together at the end of the solution order creation process.
  3. If releasing all items together is not feasible, introduce a delay between subsequent API requests to prevent locking conflicts.

See Also

Keywords

sap_wfrt, transaction locking, solution order, multiple service items, SAP S/4HANA Cloud Public Edition, business solution order, A2X, API, workflow user, locking issue, service order creation, api request, delay, solution order management , KBA , CRM-S4-SOL-SLO , S4CRM: Solution Order , Problem

Product

SAP S/4HANA Cloud Public Edition all versions