SAP Knowledge Base Article - Public

3645729 - Duplicate check/Accept Match not working while rehiring a user - SAP SuccessFactors Employee Central

Symptom

Duplicate check does not pop-up when rehiring a user. Behavior can be seen for regular employees or contingent workers, in Add New Employee or Add Contingent Worker. It affects specific users.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Add New Employee.
  2. Enter details which should trigger the duplicate check (First, Last Name).
  3. No duplicate check is triggered.

Cause

There are spaces maintained in the affected users first and/or last names. 

Resolution

  1. Go the affected users profile
  2. Highlight their first/name 
  3. Remove any extra spaces found.

See Also

2753469 - Duplicate Check for Existing Users - Employee Central

Keywords

Duplicate check, Not triggering, Duplicate Check not working, Hire, Existing details, accept match, rehire new employee, rehire inactive employee, rehire with new employment, match, popup, unable to rehire, duplicate check not coming , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions