Symptom
In the Visits and Appointments work center, standard users are unable to add additional fields or create custom queries in the Advanced Search/Filter.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Log in to SAP C4C with a user that has Key User / Admin permissions.
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Go to the Visits or Appointments Work Center (WOC).
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Click on New Meeting.
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In the meeting creation screen, select the Object View Selector (OVS) for Attendees.
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Click on Advanced Filter within the OVS.
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Select any field in the Advanced Filter screen.
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Start Adaptation Mode:
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Click on the profile icon (top right).
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Select Start Adaptation.
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Observe: there is no “Add” button available to add fields in Adaptation Mode for this Advanced Filter.
Cause
This is a system limitation.
Resolution
As it is a behavior of the system, it is necessary to raise an idea in the SAP Sales Cloud Portal requesting this functionality: Influence Page
The Customer Influence portal is the correct channel for requirements of changes in the system behavior.
There, other customers can also vote for the idea and depending on the demand from the customer community, the developers will evaluate and plan accordingly for a possible implementation of this new feature.
See Also
Reference:
SAP Guide Extension Fields Guide. (Page 30)
Keywords
advanced filter, adaptation mode, add fields, sap c4c, permissions, key user, administrator, standard user, object work list, advanced search, filter functionality, user roles, sap cloud for customer. , KBA , AP-RC-UIF , C4C UI Framework , Problem
SAP Knowledge Base Article - Public