Symptom
The "Packaged Integration - SF EC to WFS" job remains stuck in the PROCESSING state when running a full employee load.
Single users or small groups of employees are loaded successfully.
No errors are visible in CPI process logs or SuccessFactors API logs.
Environment
- CPI
- SuccessFactors Employee Central
Cause
A timeout is likely to have occurred during the execution of the CPI integration flow due to the large amount of data being processed, preventing further API calls from being sent to SAP SuccessFactors.
Resolution
Decrease page size and increase timeout values as below:
- Edit the Compound Employee API receiver and:
- Set the page size to 50 or even lower.
- Set the timeout to 10 minutes.
- Edit the other receivers (Workforce and Mapping Extension) and change their timeouts to 10 minutes.
Keywords
packaged integration, ec, wfs, cpi, full load, stuck, processing, timeout, compound employee api, page size, timeout, workforce, , KBA , LOD-SF-INT-CPI-TPI , Standard SF to 3rd Party Integration using CPI , Problem
SAP Knowledge Base Article - Public