SAP Knowledge Base Article - Public

3646571 - In app Manage My Timesheet, Overtime Categories are not visible in some languages

Symptom

In app Manage My Timesheet, Overtime Categories are not visible in some languages. For example, they are available for a user logged in with English but missing for a user logged in with German.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Connect to SAP S/4HANA Public Cloud Edition with example language German.
  2. Open app Manage My Timesheet.
  3. Enter a timesheet entry and goto the details to enter an Overtime Category.
  4. Observe that the dropdown values for Overtime Categories are missing.

Cause

Overtime Category texts are language-dependent, and the required texts for the login language have not been maintained in the configuration.

Resolution

  1. Log in with the required language.
  2. Access the Configuration Activity "Maintain Overtime Categories" (102912). Note: Depending on your configuration environment, configuration steps can be accessed under Configure Your Solution in the SAP Fiori launchpad or in the Business Processes Configuration app in the project experience of SAP Central Business Configuration.
  3. Maintain the Overtime Category texts for the required language in the configuration.
  4. Save the changes and verify that the Overtime Categories are visible in Manage My Timesheet when logged in with the required language.

Keywords

overtime categories, manage my timesheet, dropdown missing, polish language, language-dependent configuration, maintain overtime categories, s/4hana, cross application timesheet, timesheet submission, configuration activity 102912, CL_CATS_SHLP_IM_ACCOBJ_OTHER~GET_OVERTIME_CATEGORIES, i_timesheetovertimecat, i_timesheetovertimecattext , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , How To

Product

SAP S/4HANA Cloud Public Edition all versions