SAP Knowledge Base Article - Public

3646615 - Date Format for Learning data is not correct when exporting the Canvas report as excel sheet

Symptom

  • Different report formats (Excel and CSV) display inconsistent class start and end dates for the same class in Canvas LMS reports.
  • When exporting as CSV format, the date is consistent with the actual date data (ex. 12/10/2025 Oct.12th 2025) in Learning. While exporting as Excel (xlsx) , the date (10/12/2025, Dec.10th 2025) is wrong.
  • The issue only happening for date in Oct, Nov, and Dec.
  • In Excel sheet file, some date data is shown as cell format "Text", while some date data is shown as cell format "Date".

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

  • SAP SuccessFactors Learning
  • SAP SuccessFactors People Analytics

Reproducing the Issue

  1. Log in to the instance.
  2. Navigate to the Report Center.
  3. Run the Canvas LMS report which contains a date data from LMS source.
  4. Export the report to Excel format (either XLS or XLSX).
  5. Check the downloaded file and observe that the class start date displays as November 12th.
  6. Export the same report to CSV format and observe that the class start date displays as December 11th.

Cause

The issue arises due to a mismatch between the default date format settings of the LMS administrator and the BizX user.

  • The LMS administrator's default date format is set to MM/DD/YYYY (month/day/year).
  • The BizX user's default date format is determined by their locale, which for example is English (UK), with a default date format of DD/MM/YYYY (day/month/year).
  • When the data is viewed in preview mode in Canvas report, the data is displayed following the LMS admin user's date format.
  • When exporting to Excel, the tool references the BizX user's date format, causing discrepancies in date interpretation.

Note:

1. During the Exporting, the tool will convert the date-type data into the format of BizX user's preference, if the conversion result turns out to be invalid date, the cell format will be "Text".

While for other data which can be converted to a valid date, the cell format will be "Date".

2. BizX Locale default date pattern can be verified easily in "Import Employee Data" tool.

Resolution

Update the LMS administrator's default date format to match the BizX user's date format (DD/MM/YYYY).

To update the LMS administrator's date format, please follow the below steps:

  1. Log in as the LMS administrator.
  2. Navigate to the settings page for default date format.
  3. Change the date format to DD/MM/YYYY (day/month/year).

After that, Re-export the report to Excel format and verify that the class start and end dates are displayed correctly.

Please note that the date format preference will always following the Locale. Date Pattern could be changed without changing locale, however, if the admin user's locale is once changed, then the default pattern for that locale will always be applied. If you would like to avoid the impact of locale change, please change the default pattern for the locale via References>Manage Labels>Locales>Date Patterns

Keywords

SAP SuccessFactors, Canvas report, LMS, Learning Data, Date format mismatch, Class start date, Class end date, Export issue, Excel, Inconsistent dates, Bizx user locale, LMS administrator settings, Date, Text, Cell format , KBA , LOD-SF-LMS-REP , Reporting Data , Problem

Product

SAP SuccessFactors Learning all versions