SAP Knowledge Base Article - Public

3647132 - Onboardee Emails Not Anonymized After Instance Refresh

Symptom

  • After executing the instance refresh via IRT, onboardee email addresses were not anonymized in the target instance.
  • Real emails were sent from the target instance to the destination and could be viewed through the Integration Center.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Perform an instance refresh from Production to a target instance using IRT.
  2. Log in to the target instance after the refresh.
  3. Trigger an onboarding process or action that sends emails.
  4. Observe that real emails are being sent from the target instance to the destination.
  5. Verify in Integration Center that the onboardee email addresses are not anonymized and actual email IDs are visible.

Cause

This issue has been identified as a known defect in the Onboarding user management.

Resolution

  • As a workaround, an RITM must be executed.
  • Until a permanent fix is delivered by Engineering, the masking script execution is required after each refresh.

Note: @support Engineers please refer to Internal Memo.

See Also

https://help.sap.com/docs/SAP_SUCCESSFACTORS_PLATFORM/5644466b2c304e45b2e412ded198078b/abef2cf6e1564c6789bbca024b75fb16.html

Keywords

Instance refresh, IRT, TLS-33163, INC14011815, INC14265966, Target, anonymized, masked, email, ECT-252275 , KBA , LOD-SF-OBX , Onboarding 2.0 , LOD-SF-PLT , Platform Foundational Capabilities , Problem

Product

SAP SuccessFactors Onboarding 2505