Symptom
- Access Restriction authorizations are not Applied to Account Summary PDF whereas in the web browser the access restrictions are applied
- In the PDF summary, all registered products are listed, even those the user is not authorized to view
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Customers Workcenter > Account
- Search and open the relevant account
- Go to the registered products facet
Note: There are access restrictions configured to only allow the login user to view only certain registered products, for example those of the same Territory. - In the registered products the user can only see records relevant to their territory.
- Click the "Summary" button in the top right corner to generate the account summary.
- The PDF version of account opens in the browser
- Compare the products listed in the PDF with those visible in the registered products facet.
- See that the PDF includes all registered products, regardless of user authorization.
Cause
Access restrictions are not applied to the PDF summary generation process.
When the Account Summary is triggered, the system will take all the details in the account into consideration for the PDF, and access restrictions are not considered.
This results in more records displayed in the PDF summary for the user with access restrictions than expected.
Resolution
To have access restrictions apply to the PDF Summary also, please consider raising a request on the Customer Influence page. Refer to KBA 2531650 - New Customer Request for Additional Feature or Function in SAP standard software
See Also
- KBA 2531650 - New Customer Request for Additional Feature or Function in SAP standard software
- SAP Sales Cloud Community
Keywords
authorization checks, registered products, customer summary PDF, SAP Sales Cloud, access restrictions, inconsistent behavior, admin feature, PDF summary, user role, , KBA , LOD-CRM-ACC , Account , Product Enhancement
SAP Knowledge Base Article - Public