SAP Knowledge Base Article - Public

3647493 - Required fields do not have an asterisk showing besides the field label

Symptom

  • Certain required fields do not display the asterisk (*) indicator next to the field label, even though they are Required.
  • The only way you have to know if these fields are required is if you save the object without filling them, because an error message will be shown stating the same.
  • It may happen with different entities across the application.

Environment

  • SAP Service Cloud Version 2
  • SAP Service Cloud and SAP Sales Cloud Version 2

Reproducing the Issue

One example of the objects affected by this behavior is the Call Log:

  1. Open the object where you will create the Call Log
  2. Click on "+ Create"
  3. Call Log
  4. Add a Subject and try to save it.
  5. An error will be shown requesting that you fill the required fields
  6. You will notice that fields like "Contact", "Account" and "Call Results" are mandatory, even though there is no asterisk (*) on them

Cause

Some fields that are required due to specific coding logic will not display the asterisk (*) indicating mandatory status.

Resolution

A Dynamic Property will need to be created to set the field as Required, and that will display the asterisk (*) indicating that the field is Required before the user saves the object and get the error message.

See Also

KBA 3587077 - How To Change Custom and Standard Field Properties under Extensibility Administration for Case Entity

Keywords

mandatory fields, phone calls, dynamic property, required fields, asterisk missing, field validation, backend validation, extension settings, ui missing fields , KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To

Product

SAP Service Cloud Version 2 all versions