SAP Knowledge Base Article - Public

3647523 - Not possible to select Access Category inside a Business Role

Symptom

You created a Business Role and when setting the "Access Category", the "Write, Read, Value Help" only allows you to select "No Access". 

Environment

SAP S/4HANA Cloud Public Edition 

Reproducing the Issue

  1. Go to Maintain Business Roles app
  2. Open the business role 
  3. Go to edit mode
  4. Check the Write Read Value Help Access Category

Cause

There are no IAM Apps active in the Business Role and therefore the only Access Category possible was "No access" since there are no applications being authorized with the role. 

Resolution

You need to activate at least one application. Follow the steps below:

  1. Go into the IAM Apps inside the Business Role
  2. Select the apps you want to grant access
  3. Click on Activate
  4. Go back to General tab 
  5. Now it's possible to change the Access Category

See Also

For more information about IAM Apps concept, check the following documentations:

Keywords

business role, iam app, active, activation, application, access category, write, read, value help, no access, restricted, unrestricted , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions