Symptom
You created a Business Role and when setting the "Access Category", the "Write, Read, Value Help" only allows you to select "No Access".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Maintain Business Roles app
- Open the business role
- Go to edit mode
- Check the Write Read Value Help Access Category
Cause
There are no IAM Apps active in the Business Role and therefore the only Access Category possible was "No access" since there are no applications being authorized with the role.
Resolution
You need to activate at least one application. Follow the steps below:
- Go into the IAM Apps inside the Business Role
- Select the apps you want to grant access
- Click on Activate
- Go back to General tab
- Now it's possible to change the Access Category
See Also
For more information about IAM Apps concept, check the following documentations:
Keywords
business role, iam app, active, activation, application, access category, write, read, value help, no access, restricted, unrestricted , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
SAP Knowledge Base Article - Public