SAP Knowledge Base Article - Public

3647541 - Utilities Bill Forms Are Not Visible While Editing Collective Contract Accounts

Symptom

When editing a C4C Collective Contract Account, the bill forms created under class IS_U_BI_COLLECTIVE_BILL_NEW are missing.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Utilities facet. 
  2. Open a Collective Contract Account. 
  3. Click on "Edit Contract Account".
  4. Select the "Bill Form" dropdown.

Cause

The C4C contract account category is not set as collective.

Resolution

Maintain the Contract Account Category in the C4C Fine-Tuning:

  1. Go to the Business Configuration work center and click on Overview.
  2. Search for Utilities.
  3. Open Utilities Activity and click on Contract Account Category.
  4. Set the "Collective Flag" for the relevant category.

Keywords

edit contract account, field display issue, user entries not displayed, utilities, contract account defect, field visibility problem, troubleshooting , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer add-ins all versions