Symptom
User is unable to create new Service Quotes or find any configurations related to Service Quotes in the system.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
There are two ways in which issue can be observed:
- Scenario 1:
-
- Go to User Profile.
- Click on Settings.
- Under All Settings, search for 'Service Quotes'.
- Notice that no results are returned.
- Scenario 2:
-
- From the Navigation Menu, go to Service Quotes Workcenter.
- Notice that there is no option to create (+) new Service Quotes or a refresh icon on the OWL screen.
Cause
Issue can occur due to the following reasons:
- Incorrect or Missing Authorization for the user.
- Feature not enabled in the tenant.
- Creation of Service Quotes directly in the system is not supported.
Resolution
- If it is the first case as mentioned above, in order to configure and view Service Quotes in the system, user must be assigned to the below Business Service and Apps:
- sap.crm.service.serviceQuotationService - Service Quotation (Business Service)
- sap.crm.service.serviceQuotationService - Service Quotes (App Name)
- sap.crm.service.serviceQuotationService - sap.crm.servicequotationservice.uiapp.serviceQuotationAdmin (App Name)
- If it is the second case as mentioned above, after adding the necessary Services and Apps in Business roles, if the Service Quote configuration is still not accessible in the system, then a request needs to be raised to SAP via a Case to activate the Service Quote feature in the system.
- Service Quotes need to be created from an external system. Users can create the service quotes with the customers via connector service.
See Also
SAP Help Documentation - Service Quotes
Keywords
Service Quotes, Configuration, Activate, Create, Missing, Refresh, Quotation, External System, Business Service, Apps , KBA , CEC-CRM-SRVQ , Service Quotation for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public