Symptom
Attachments, which are included in the E-mail Template, are not displayed when you use the template for an e-mail.
Environment
SAP Cloud for Customer
Reproducing the Issue
This is an example for a Lead scenario but applies for other Sales Business Object scenarios.
- Go to the Sales work center
- Go to the Lead work center view
- Open a Lead
- Go to the Activities tab
- Click New in the E-mail section
- Select an e-mail template which includes attachments
- Click Select
Result: The attachments in the E-mail Template are not displayed in the Attachments section.
Cause
Attachments are loaded once a round-trip to backend is done. By selecting an E-mail Template, this action is not taken in the system.
Resolution
Add a signature in My Email Settings. *Use actual signature or create a dummy signature (e.g. a dot with white text colour)
- Click the user menu
- Click the Settings
- Select My Email Settings
- Select a Signature template for New Email and Replies/Forwards
- Click Save and Close
Keywords
e-mail, attachments, template, display, view, visible, missing , KBA , LOD-CRM-ACT , Activities , How To
SAP Knowledge Base Article - Public