SAP Knowledge Base Article - Public

3648360 - Attachments Not Displayed When Creating E-mail with Template

Symptom

Attachments, which are included in the E-mail Template, are not displayed when you use the template for an e-mail.

Environment

SAP Cloud for Customer

Reproducing the Issue

This is an example for a Lead scenario but applies for other Sales Business Object scenarios.

  1. Go to the Sales work center
  2. Go to the Lead work center view
  3. Open a Lead
  4. Go to the Activities tab
  5. Click New in the E-mail section
  6. Select an e-mail template which includes attachments
  7. Click Select

Result: The attachments in the E-mail Template are not displayed in the Attachments section.

Cause

Attachments are loaded once a round-trip to backend is done. By selecting an E-mail Template, this action is not taken in the system.

Resolution

Add a signature in My Email Settings. *Use actual signature or create a dummy signature (e.g. a dot with white text colour)

  1. Click the user menu
  2. Click the Settings
  3. Select My Email Settings
  4. Select a Signature template for New Email and Replies/Forwards
  5. Click Save and Close

Keywords

e-mail, attachments, template, display, view, visible, missing , KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer core applications all versions