SAP Knowledge Base Article - Public

3648594 - Default Filter Configuration Does Not Apply When Accessing Inbox via Shortcut in My Launchpad

Symptom

After a specific filter is chosen as the default filter for the inbox, reopen the inbox via the "All Open Items" or other quick link, the system does not apply the chosen default filter.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Home -> My Launchpad.
  2. Click on "All Open Items".
  3. Observe that the system displays the "All Open Items" filter.
  4. Open the advanced filter.
  5. Click on "Organize Queries".
  6. Choose another query, such as "Closed Items", as the default.
  7. Apply the changes.
  8. Close the inbox.
  9. Reopen the inbox by clicking on "All Open Items".
  10. Observe that the default query is still "All Open Items" instead of the newly selected default filter.

Cause

This is the designed system behavior.

Resolution

The "All Open Items" quick link is a pre-defined SAP shortcut that loads a specific configuration for the inbox UI. This pre-defined configuration is embedded within the quick link and will override any default filter settings configured in the inbox UI. 

The default query will be applied when directly access the inbox UI via the traditional navigation path (e.g., Home -> Inbox).

Keywords

Default Filter, Inbox Filter, Quick Link, All Open Items, Advanced Filter, Organize Queries, Default Query, Inbox , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , Problem

Product

SAP Business ByDesign all versions