SAP Knowledge Base Article - Public

3648665 - Error "Removal of OAuth not possible; client is already registered for same IDP"

Symptom

Error "Removal of OAuth not possible; client is already registered for same IDP" occurs while deleting configuration in Configure OAuth 2.0 Identity Provider. 

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Navigate to "Configure OAuth 2.0 Identity Provider" -> Select the configuration 
  2. Try to delete the configuration
  3. Below error occurs

"Removal of OAuth not possible; client is already registered for same IDP"

Cause

The configuration has to be deleted first in OAuth2.0 Registered Client. 

Resolution

  1. Navigate to Administrator -> OAuth2.0 Registered Client.  
  2. Delete the configuration here
  3. Navigate to "Configure OAuth 2.0 Identity Provider" -> Select the configuration 
  4. Try to delete the configuration

The deletion will be successful

See Also

Refer to: Configuring OAuth 2.0 between SAP Sales Cloud and SAP BTP.

Keywords

oauth2samlbearerassertion, sap sales cloud, sap btp, destination configuration, authorization grant invalid, email address mapping, issuer name mismatch, oauth2 identity provider, integration error, saml assertion. , KBA , BC-SEC-LGN-OA2 , OAuth 2.0 for ABAP , Problem

Product

SAP Cloud for Customer core applications all versions