SAP Knowledge Base Article - Public

3648679 - Unable to save region in user profile

Symptom

  • Market selection drop-down is empty, and an error message appears like "The parameterized query '(@USERNAME *******,@PASSWORD ****,@NAME <*USER-PASSWORD*:(1' expects the parameter '@COUNTRY', which was not supplied."

     • Users are unable to save changes to their profile settings due to this issue.

Environment

SAP Sales Cloud CPQ

Reproducing the Issue

  1. Open CPQ and navigate to the User Profile page.
  2. Go to the 'Modify personal details' tab.
  3. Select a country/region and press save.
  4. Attempt to select any market from the Market drop-down under user details.
  5. Enter additional information (e.g., Back-up name) and save.
  6. Observe that the changes are not saved, and the Market drop-down remains empty.

Cause

• The issue occurs when users in the system have an invalid country that does not exist in the system.

• Customization for the "Modify Personal Details" page does not set a country for the user, causing saving changes to fail. 

Resolution

  1. Ensure that when users are created via the SCIM API, a valid country is included in the payload.
  2. If it is not possible to send a country value in the SCIM API payload, modify the customization to include a hidden field for the country. For example:

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See Also

Refer to: SAP Note on SCIM API Configuration

Keywords

user profile settings, prime market selection, sales cloud cpq, user data not saving, invalid country, scim api, modify personal details, country parameter missing, production environment, cpq user profile issue , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions