SAP Knowledge Base Article - Public

3648945 - Items synced using server side integration are showing obsolete user ID

Symptom

Emails synced by users from outlook to C4C using server side integration, shows that it is done by an older obsolete user ID of the same user

Environment

SAP Cloud for Customer

Reproducing the Issue

Below is a test scenario with an example "User A"

  1. User A gets a new user ID and older ID becomes obsolete, both have the same email ID
  2. User A syncs an email from Outlook to C4C
  3. Email in C4C shows that it was created by User A's older, obsolete user ID

Cause

This is the expected behavior. When the user was initially created in SSI, it was done with and associated to the initial email and user ID. When the initial user ID became obsolete and a new one was created, and the same email is used for the new user ID, the update does not take place in SSI and the older association still exists.

Resolution

The user needs to be re-provisioned in SSI so that the association between the new user ID and SSI user ID is updated

Keywords

Obsolete,SSI, Server side integration, sync, Email, Items, emplyee, ID, old , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem

Product

SAP Cloud for Customer core applications 2508