Symptom
The Confirm Part button is not displayed for Parts section inside Tickets, despite the button being set as visible via Adaptation Mode.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service > Tickets.
- Open the desired Ticket.
- On Parts section, select an item.
- Click on More button.
- There is no Confirm Part option available.
- Click on Profile and Start Adaptation.
- Click on the pencil for the More button inside Parts section.
- On the Adaptation screen, click on Menu.
- Although the Confirm Part option is marked as visible, it is not being displayed.
Cause
The Confirm Part button has a visibility logic that will set it is as visible for the item selected, only under below conditions:
- If the selected item's "Service Transaction Processing TypeCode" is "Part Advance Shipment to Customer Consignment Stock".
and
- If the "External Follow-Up Processing Release Status Code" is "Released".
If any of these conditions are not met, the button will remain hidden. The visibility automatically updates when any of the relevant fields change.
Resolution
This is the expected system behavior.
To confirm if the items have the expected values or not, the "Service Transaction Processing TypeCode" can be found as "Processing" column under Parts section in UI. While the "External Follow-Up Processing Release Status Code" can be checked on the related ERP system.
Keywords
products, displays, not displaying, does not display, does not show, not shown, not showing, ECC, integration, integrated, S4, external system, personalization, facet, tab, not working, greyed out, grayed out, not found, cannot show, cannot display, can not, can't, not being visible, not appearing, does not appear, cannot appear, enable, unable, disable, not able, C4C , KBA , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public