Symptom
- The compliance switch for the United States, United Kingdom and Australia in the onboarding compliance settings page is not enabling. After enabling the switch and refreshing the page, the switch reverts to inactive.
- Intermittent failures observed in the "Onboarding Compliance Metadata Sync Job" from the Provisioning
- Error Code: "Network issue. IOException during upload" in Maintain Onboarding and Offboarding Templates
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to the compliance settings page.
- Enable the switch for USA, UK or AUS.
- Refresh the page and observe that the switch reverts to inactive.
Cause
- The issue may be caused by a typographical error in the PFS link where "Odata" needs to be corrected to "odata".
- Permissions for the job owner to onboarding compliance objects may be missing.
- The PFS password may need to be reset.
Resolution
- Verify the PFS link and ensure the word "Odata" is corrected to "odata".
- Trigger the "Onboarding Compliance Metadata Sync Job" and confirm that it completes successfully.
- Perform an odata refresh and attempt to enable the I-9 switch in the compliance settings.
- If the job continues to fail, ensure the job owner has permissions to onboarding compliance objects.
- If the issue persists, reset the PFS password using the associated P-user.
See Also
Keywords
obx, compliance settings, compliance switch, usa switch, us switch, aus switch, uk switch, switch disabling, inactive switch, onboarding compliance metadata sync job , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public